User
Pass
2FA
 
 

[FIXED] [General] Speed stat not working

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Freakz Forum Index -> WoW Freakz - Legion -> Bug Report -> Fixed bugs
Show only staff posts
Author Message258
bakubakuForum

[Mentally Stable]



Status: Offline
(since 29-10-2019 15:29)
Joined: 28 Jan 2018
Posts: 22, Topics: 11
Location: The Netherlands

Reputation: 62.7
Votes: 7

Post Posted: 29-12-2018, 19:36:46 | Translate post to: ... (Click for more languages)

As of 7.2.5, the Speed stat found on gear not does increase movement speed at all.

Proof (not just a tooltip bug): https://i.imgur.com/2jeR5ao.png

0 0
  
Back to top
View user's profile Send private message
Quicksand

[WoW Dev]



Status: Offline
(online 6 days ago)
Joined: 21 Feb 2017
Posts: 6116, Topics: 275
Location: Romania

Reputation: 1265.5
Votes: 189

Post Posted: 31-12-2018, 02:20:41 | Translate post to: ... (Click for more languages)

Fixed
0 0
  
Back to top
View user's profile Send private message

  Topic locked


Topic is closed, you cannot post any messages in it anymore

Locked by Quicksand, 31 December 2018 01:20



 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Freakz Forum Index -> WoW Freakz - Legion -> Bug Report -> Fixed bugs  


The time now is 08-12-2019, 05:15:40
Copyright info

Based on phpBB ro/com

 
 
 







I forgot my password


This message appears only once, so
like us now until it's too late ! :D
x